fix(provider)!: drop Python 3.7, 3.8 support #33088

Problem: #33022 didn't update `min_version` to 3.9, therefore Python 3.7
and 3.8 are still available.

Solution: Update `min_version` to 3.9.
This commit is contained in:
v1nh1shungry authored and GitHub committed 2025-03-28 04:49:10 -07:00
1 parent 75cbd9a8ae
commit ade58885c4
2 files changed
+2 -2

No files matched your search

+1 -1
View File
@@ -35,7 +35,7 @@ if you already have it (some package managers install the module with Nvim
itself).
For Python 3 plugins:
1. Make sure Python 3.4+ is available in your $PATH.
1. Make sure Python 3.9+ is available in your $PATH.
2. Install the module (try "python" if "python3" is missing): >bash
python3 -m pip install --user --upgrade pynvim
+1 -1
View File
@@ -1,5 +1,5 @@
local M = {}
local min_version = '3.7'
local min_version = '3.9'
local s_err ---@type string?
local s_host ---@type string?