Update required Python to 2.5.

This commit is contained in:
Georg Brandl committed 2012-10-30 09:55:44 +01:00
1 parent ede91a36d0
commit 2671d55436
2 files changed
+8 -24

No files matched your search

+2 -18
View File
@@ -46,25 +46,9 @@ A development egg can be found `here
requires = ['Pygments>=1.2', 'Jinja2>=2.3', 'docutils>=0.7']
if sys.version_info < (2, 4):
print('ERROR: Sphinx requires at least Python 2.4 to run.')
sys.exit(1)
if sys.version_info < (2, 5):
# Python 2.4's distutils doesn't automatically install an egg-info,
# so an existing docutils install won't be detected -- in that case,
# remove the dependency from setup.py
try:
import docutils
if int(docutils.__version__[2]) < 4:
raise ValueError('docutils not recent enough')
except:
pass
else:
del requires[-1]
# The uuid module is new in the stdlib in 2.5
requires.append('uuid>=1.30')
print('ERROR: Sphinx requires at least Python 2.5 to run.')
sys.exit(1)
# Provide a "compile_catalog" command that also creates the translated